RSS feed

CVSd Doubt

[Date Prev][Date Next] [Thread Prev][Thread Next]

CVSd Doubt

Dear friend,


I am getting crazy with the configuration of the cvsd.

After reading all posts, configuration hints of youw website, and a big amount of foros, I can’t deal with my problem:


It is simple, I always get the error:


Fatal error, aborting.

cvsd: no such system user


I get it when I try to connect to the cvs from my client (eclipse), but also when executing the command

cvs -d :pserver:anonymous@localhost:/myrepos checkout .


I checked lot of times all the lines indicated in your readme file:


  # addgroup --system cvsd       (or groupadd)

  # adduser --system --ingroup cvsd --home /var/lib/cvsd \

            --shell /bin/false --gecos 'cvs pserver daemon' cvsd

  # cvsd-buildroot /var/lib/cvsd

  # cvs -d /var/lib/cvsd/myrepos init

  # cvsd-passwd /var/lib/cvsd/myrepos +anonymous

  # touch /var/lib/cvsd/myrepos/CVSROOT/writers

  edit /var/lib/cvsd/myrepos/CVSROOT/config

    add "SystemAuth=no"

    add "PamAuth=no"      (on systems that have this option)

    add "LockDir=/tmp/myrepos"

  # mkdir /var/lib/cvsd/tmp/myrepos

  # chown cvsd:cvsd /var/lib/cvsd/tmp/myrepos

  edit /etc/cvsd/cvsd.conf

    set "RootJail /var/lib/cvsd"

    set "Repos /myrepos"


-          I tried to create a anonymous user, and other users with password… always getting the same error.

-          I checked passwd configuration file, everything seems to be fine.

-          I reinstalled the cvsd and cvs

-          I have an ubuntu server.


Please, could you help me?


Thanks in advance.

Best Regards,

 Ignacio Yagüe Martín
 Vision and Lighting Systems Domain (MERV)
 Pº John Lennon s/n - E28906 Getafe (Madrid) - SPAIN
( (+34) 91 624 3234 · 7 (+34) 91 624 2705


To unsubscribe send an email to or see