RSS feed

Re: Problem on Centos 7 - segfault in libc

[Date Prev][Date Next] [Thread Prev][Thread Next]

Re: Problem on Centos 7 - segfault in libc


I reslove the problem. It's not a problem with nss-pam-ldapd or libc. I have PAM module from RSA (which I forget). It's working good, but not with pam_ldap. When I configure module rsa or pam_ldap is't ok, but not when both is active. Valgrind helps to resolve this.

To do working both modules, I've configure RSA module, to return PAM_INGORE if the username is not at supported for RSA auth.

Sorry for too fast issue report.

Best regards

Łukasz Górowski
tel. +48 32 7574269
mobile: +48 785 550 186
Centralny Ośrodek Informatyki Górnictwa Spółka Akcyjna, NIP: 634-013-4205
40-065 Katowice, ul. Mikołowska 100, Sąd Rejonowy Katowice-Wschód w Katowicach,
VIII Wydział Gospodarczy Krajowego Rejestru Sądowego KRS 0000092497,
Kapitał zakładowy w kwocie: 5.400.000 zł, w całości wniesiony,
Tel: +48 32 757-48-98  ,

W dniu 12.09.2014 18:03, Jakub Hrozek pisze:
On 05 Sep 2014, at 10:26, Łukasz Górowski <> wrote:


I have problem with configure nss-pam-ldapd on Centos 7 x64. The same 
configuration working on Centos 5/6.Getent passwd and group works great but 
when I try log in to the machine I get error in dmesg (the same error is when I 
log from locall console or ssh):

[ 2167.250732] sshd[4225]: segfault at 0 ip 00007ffff52b4df6 sp 
00007fffffffd518 error 4 in[7ffff5183000+1b6000]

local console:
[57513.597122] login[25144]: segfault at 0 ip 00007f9eda447e57 sp 
00007fff09d97c18 error 4 in[7f9eda316000+1b6000]

I don't know what to do now, because i have project to migrate from old Centos 
5. I was trying version 0.9.4, 0.814, 0.7.15 with no effect. My programming 
skills isn't good enough to fix/debug this problem.

I think you should install and enable abrt to ease the process of generating 
core files and back traces. I’m sure there’s plenty of howtos online :-)

I think the problem can be in libc because I have the same error when I try 
configure sssd
Not saying you’re wrong, but I suspect there’s something wrong about the way 
either of the projects use some libc interface.

(but I wolud like to use nss-pam-ldapd instead sssd).

May I know why? Feel free to respond to this part of the question privately, 
this is nss-pam-ldapd list after all.

Best regards.

Łukasz Górowski

To unsubscribe send an email to or see

To unsubscribe send an email to or see