RSS feed

Re: unlink of socket failed and no such object

[Date Prev][Date Next] [Thread Prev][Thread Next]

Re: unlink of socket failed and no such object

On Thu, 2015-05-14 at 16:31 -0700, Pete Greenup wrote:
> nslcd: DEBUG: unlink() of /var/run/nslcd/socket failed (ignored): No
> such file or directory

This should only happen on start-up and can be safely ignored.

> nslcd: [3c9869] <authc="xuser"> DEBUG: "xuser": user not found: No
> such object

This means that nslcd is not able to find the user in LDAP. If you can
find the user with ldapsearch, it probably indicates a configuration

> I have tried un-commenting and commenting a few different fields in
> the active directory section of my nslcd.conf, but am thinking i might
> need to do something more specific?

Your nslcd.conf has two binddn options. If you LDAP server requires
binding before searching you need to configure binddn and bindpw.

You also map the uid attribute to cn but your ldapsearch uses the uid
attribute so you should probably disable that mapping. Also be sure that
the filter you configured in nslcd.conf all map to attributes found in
the LDAP server.

Right before the "user not found" error nslcd should log which search it
tried to perform (in debug mode). This should provide information on why
the search failed.

Kind regards,

-- arthur - - --
To unsubscribe send an email to or see