RSS feed

Re: CVS server is not working after power outage.

[Date Prev][Date Next] [Thread Prev][Thread Next]

Re: CVS server is not working after power outage.

"kamil kapturkiewicz" writes:
- We have CVS server in our company, it was configured long time
- before I joined.  Server had ~600 days of uptime, but during last
- weekend we had a power outage.  After that CVS has stopped working
- and it is unclear for me what exactly went wrong.

Do you have a "cvs pserver" entry in your inetd.conf or your
xinetd configuration?

- System is Debian 6.0.7 (Squeeze)
- CVS version is 1.12.13
- Users are configured in NIS and it is working properly after crash.
- All repositories are located in /usr/cvsroot
- /etc/cvsd/cvsd.conf:
- RootJail /var/lib/cvsd
- Uid cvsd
- Gid cvsd
- Nice 1
- Umask 027
- PidFile /var/run/
- MaxConnections 10
- Log syslog info
- Listen * 2401
- Repos /demo
- Repos /myrepos

Looks good, assuming that /demo and /myrepos exist under

- /etc/cvs-pserver.conf:

Never heard of a /etc/cvs-pserver.conf file.

- 1. I tried to run cvsd as root
- 2. I tried to add Repos /usr/cvsroot to cvsd.conf
- 3. I tried to make soft link to /usr/cvsroot to /var/lib/cvsd/usr/cvsroot, 
- but got:
- cvs [checkout aborted]: unrecognized auth response from cvs: cvs pserver: 
cannot open /usr/cvsroot/CVSROOT/config: Too many levels of symbolic links

This suggests you were talking to a "cvs pserver" instance that
was started from inetd/xinetd, and not via cvsd.

Eric Schnoebelen         
 In order to pull a rabbit out of a hat, is is necessary first to put one in.
To unsubscribe send an email to or see