RSS feed

Re: CVS server is not working after power outage.

[Date Prev][Date Next] [Thread Prev][Thread Next]

Re: CVS server is not working after power outage.

On Tue, 2015-07-28 at 17:11 +0200, kamil kapturkiewicz wrote:
> We have CVS server in our company, it was configured long time before
> I joined. Server had ~600 days of uptime, but during last weekend we 
> had a power outage. After that CVS has stopped working and it is 
> unclear for me what exactly went wrong.
> System is Debian 6.0.7 (Squeeze)
> CVS version is 1.12.13
> Users are configured in NIS and it is working properly after crash.
> All repositories are located in /usr/cvsroot

There are two ways of running a pserver:
- configured via the cvs package (using inetd)
- configured via the cvsd package

The second is a wrapper around cvs but you should not configure both at
the same time. From the information you provided it seems that cvsd is
not used. You should probably not have it running in this case and
ensure that your (x)inetd is configured to listen on port 2401.

> 2. I tried to add Repos /usr/cvsroot to cvsd.conf

This will not work because repositories need to be under /var/lib/cvsd
for cvsd to be able to pick them up.

> 3. I tried to make soft link to /usr/cvsroot to 
> /var/lib/cvsd/usr/cvsroot, but got:
> cvs [checkout aborted]: unrecognized auth response from cvs: cvs 
> pserver: cannot open /usr/cvsroot/CVSROOT/config: Too many levels of 
> symbolic links

Symbolic links will not work under /var/lib/cvsd because they cannot be
resolved in a chroot jail.

> 6. I tried to run cvsd-buildroot -d /usr/cvsroot as described at: 

You should probably clean up /usr/cvsroot then because it installs all
kinds of files that should not be there. cvsd requires a chroot jail
that can be created and maintained with cvsd-buildroot. It should not
be called on repositories.

-- arthur - - --
To unsubscribe send an email to or see