RSS feed

id command shows only primary group

[Date Prev][Date Next] [Thread Prev][Thread Next]

id command shows only primary group

I have a new CentOS client (7.1) with a nslcd.conf that worked with 6.x
machines. In the new machine I can bind and query ldap without any issues.
However, "id <username>” only shows the primary group. “getent group|grep
primary_group” does not display the members — only the group name and gid:

My LDAP server is running CentOS 6.6. Is there something new/different in
nslcd.conf for CentOS 7.1? I also tried with different filter options but
same result. "Nslcd -d"
didn’t show any errors.

# rpm -qa|grep nss-pam


uid nslcd
gid ldap

uri ldaps://myldap-server1 ldaps://myldap-server2

base dc=bw,dc=ncsa,dc=illinois,dc=edu
base netgroup       ou=netgroup,dc=bw,dc=ncsa,dc=illinois,dc=edu
base passwd ou=People,dc=bw,dc=ncsa,dc=illinois,dc=edu
base group  ou=Group,dc=bw,dc=ncsa,dc=illinois,dc=edu

filter passwd (objectClass=posixAccount)
tls_cacertdir /etc/openldap/cacerts
tls_cacertfile /etc/openldap/cacerts/cacert.pem



Sharif Islam 
Senior System Engineer
Blue Waters (
3006 E NCSA, 1205 W. Clark St. Urbana, IL

To unsubscribe send an email to or see