RSS feed

Re: Build nslcd for Solaris 10 and Solaris 11

[Date Prev][Date Next] [Thread Prev][Thread Next]

Re: Build nslcd for Solaris 10 and Solaris 11

On Wed, 2018-01-17 at 13:40 +0100, Dirk Gloede wrote:
> I try compile nss-pam-ldapd on Solaris 11.3 and Solaris 10 u11, but
> it failed.

What errors are you getting?

In general, nss-pam-ldapd is most thoroughly tested together with
OpenLDAP client libraries but it worked on Solaris in the past.

One thing I did find on Solaris 10 11 is that the C library handles the
ldap name in /etc/nsswitch.conf differently and seems to do some hard-
coded special handling.

This is what I use on my Solaris 10 test machine:

export PATH=/sbin:/usr/sbin:/usr/bin:/usr/sfw/bin:/usr/ccs/bin:/usr/local/bin
./configure --enable-warnings --with-module-name=ldapd PATH="$PATH"

It is pretty clear that the NSS module API in Solaris not not really
meant for third-party providers because the API changes between Solaris
versions and is largely undocumented.

In the past I ran some Solaris machines and the default-provided LDAP
NSS modules were pretty OK (although you have to have some schema
tweaks if you also want automounter maps from LDAP).

Hope this helps,

-- arthur - - --
To unsubscribe send an email to or see