RSS feed

nslcd: ldap_result() timed out

[Date Prev][Date Next] [Thread Prev][Thread Next]

nslcd: ldap_result() timed out


I'm administrating a little network with a debian squeeze server (with homes 
and ldap) and several squeeze clients.

My configuration in general works and my users can login and use their home 
from the server. However, I have an strange problem with some boxes and I'm 
really stumbed because I really don't know what to do.

With some boxes the user session is blocked during some seconds, every some 
minutes. I have looked all the config files and the _only_ thing that i have 
found is that the computer lost the ldap connection, so the client know 
nothings about the user (uid, groups, permissions, etc) and blocks the session 
till know the info.

In the /var/log/messages I got a lot of:
Oct  4 12:01:22 sira nslcd[27037]: [fd6b4f] ldap_result() timed out
Oct  4 12:01:57 sira nslcd[27037]: [46b5a9] ldap_result() timed out
Oct  4 12:02:50 sira nslcd[27037]: [ee1348] ldap_result() timed out

The strange thing to me is that I use the same configuration files (nslcd.conf, 
etc ..) in several boxes worked perfectly in some and not working in another. 
The boxes are connected to the same switch, so I would like to think that it's 
not a hardware problem.

I have tried to make a backport of the new version of nss-pam-ldapd, with the 
same result, but I don't know if I did it ok, because with wheezy and the 
multi-arch the packages libraries is a bit different and I don't dominate the 
debian packaging.

Also, I have tried to debug nslcd, but I have not found any significant 
message. Worst, I have the feeling that it was working better in debug mode.

So, please, could you give me some idea of what's going here?, or some light 
about how to know how to solve it?

Best regards,


To unsubscribe send an email to or see